We believe we have identified the fault that was causing issues connecting to the Author module, and our operations team have deployed a fix. - This fix should make it possible for everyone to connect to Author via browser. - Remote Desktop Connections will be possible for most users, but you may experience issues if your registry has been set to RDGClientTransport=1.
For users experiencing this issue, you can view more information on status.author-it.com (see the update dated Aug 22, 2024 - 07:57 UTC) and we’ll be posting the same information to Author-it Community soon. We will continue to monitor the situation.
We sincerely apologize for the inconvenience this has caused.
Posted Aug 23, 2024 - 02:27 UTC
Update
Hello, we are aware of the impacting issue we're facing with accessing Author (through Remote Desktop Connection - via Desktop and Browser both). We are working extremely hard with our Operations, Development and Infrastructure team to resolve this issue as soon as possible, this is our top priority. We will continue to update you as soon as there is a fix or workaround.
Posted Aug 23, 2024 - 00:29 UTC
Update
Important Update Regarding RDP Stability and Protocol Changes =========================================
Dear Customer,
We would like to update you about the ongoing stability issues you may have experienced while connecting to Author via Remote Desktop Connection.
Previously, Microsoft made changes to the Remote Desktop Protocol (RDP) that led to connection problems for computers using modern protocols instead of the “legacy” RDP protocol (Remote Procedure Call over HTTP). These were commonly resolved by hard-coding the registry to set RDGClientTransport=1 which enforced the use of the legacy protocol.
In July 2024, Microsoft released a patch set (KB5040430, KB5040434, KB5040437) that introduced instability in connections to the Remote Desktop Gateway service, causing intermittent drops to RDP connections. Microsoft has acknowledged that these patches impact the legacy protocol.
At the end of July, we removed this patch set so that we could continue to support the legacy protocol and provide you with maximum flexibility. However, with the latest updates, this patch set has become mandatory and cannot be removed without causing other functions within the Remote Desktop Gateway to stop working.
Given this development, we plan to disable the legacy protocol and require the use of Microsoft’s preferred protocols. This change may affect customers who have forced the use of RDGClientTransport, potentially making them unable to open the Author module via Remote Desktop Connection.
Before we disable the legacy protocol, we strongly recommend that your IT department reviews your registry settings and makes any necessary changes to your Group Policy Objects (GPOs) to prevent a potential loss of service.
You may need to either remove this registry key or set it as a DWORD with value 0.
Our current intention is to disable the legacy protocol as soon as possible, and no later than mid-September 2024.
Please note that we don’t expect this change to impact the ability to open Author in the browser, though this is still to be confirmed.
We appreciate your cooperation and will continue to monitor the situation and provide updates as necessary.
Posted Aug 22, 2024 - 07:59 UTC
Monitoring
We believe that services have been restored, but will continue to monitor the situation for a while.
Posted Aug 21, 2024 - 03:24 UTC
Update
We have partially restored service to Author RDP & Author RDP Browser services. Service degradation and intermittent connection losses should be expected over the next few hours.
Posted Aug 21, 2024 - 02:50 UTC
Identified
The RDP services in GX1 have failed to come back online. We are currently working on this issue.
Other services including Contribute appear to be functioning properly.
Posted Aug 21, 2024 - 02:07 UTC
This incident affected: Status Page Email Notifications.