RDP connection issues

Incident Report for Authorit Cloud Services

Resolved

This incident has been resolved.
Posted Sep 12, 2025 - 03:59 UTC

Update

Systems appear normal again
Posted Sep 12, 2025 - 03:26 UTC

Monitoring

Systems appear normal. Will continue to monitor
Posted Sep 11, 2025 - 21:55 UTC

Investigating

Remote desktop is currently encountering issues, we are working hard on bringing access back to all effected parties
Posted Sep 11, 2025 - 19:51 UTC
This incident affected: Author-it Cloud (GX2).