Author-it Cloud UnPlanned Maintenance

Incident Report for Authorit Cloud Services

Resolved

This incident has been resolved.
Posted Sep 30, 2025 - 21:18 UTC

Monitoring

Applied emergency updates, apologies for unexpected outage
Posted Sep 30, 2025 - 21:06 UTC
This incident affected: Author-it Cloud (GX2).