Author is failing to load for some users some of the time

Incident Report for Authorit Cloud Services

Resolved

This incident is now resolved and users can access Author.
Posted Jul 29, 2025 - 20:03 UTC

Investigating

Author is failing to load in both Desktop and Browser modes for some users some of the time. Using a Private Browser and trying multiple times can provide access (it can take quite a few attempts) for some users. We're aware of the behaviour, have identified what we believe the problem to be and are working on a solution.
Posted Jul 29, 2025 - 18:00 UTC
This incident affected: Author-it Cloud (GX2).