Publishing to Magellan (performance)

Incident Report for Authorit Cloud Services

Update

Some customers continue to experience reduced performance during the publishing of Magellan. This is most noticeable for larger books. The issue appears to be related to network performance when a large number of files are involved or generated by the publishing process. We continue to work with AWS to identify the cause of this issue and sincerely apologise for the inconvenience.
Posted Jul 01, 2025 - 02:50 UTC

Update

We are still investigating an issue where publishing large books to Magellan takes longer for certain customers. We are working closely with AWS to resolve it. Thank you for your patience.
Posted Jun 27, 2025 - 01:39 UTC

Investigating

We are currently investigating an issue where publishing to Magellan is taking longer than expected for some customers.
Posted Jun 25, 2025 - 00:54 UTC
This incident affects: Author-it Cloud (GX1, GX2).